Нужно определить сколько лет и месяцев во введенном количестве месяцев? Используйте следующую формулу, чтобы сделать это.

=ЕСЛИ(ОКРУГЛВНИЗ(A1/12;0);ОКРУГЛВНИЗ(A1/12;0)&ЕСЛИ(ИЛИ(ОКРУГЛВНИЗ(A1/12;0)=1;И(ОКРУГЛВНИЗ(A1/12;0)>20;ОСТАТ(ОКРУГЛВНИЗ(A1/12;0);10)=1));" год";ЕСЛИ(И(ОСТАТ(ОКРУГЛВНИЗ(A1/12;0);10)>1;ОСТАТ(ОКРУГЛВНИЗ(A1/12;0);10)<5;ИЛИ(ОКРУГЛВНИЗ(A1/12;0)<12;ОКРУГЛВНИЗ(A1/12;0)>14));" года";" лет"));"")&" "&ЕСЛИ(ОСТАТ(A1;12);ОСТАТ(A1;12)&" мес.";"")

 

Добавить комментарий


Защитный код
Обновить

Вверх